В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
skawin2017
skawin2017
31.03.2021 02:29 •  Информатика

Задан двумерный массив С[n][m] (1 <p, m <20). Найдите наибольший
элемент в этом массиве.​

Показать ответ
Ответ:
RaritetnuWioN
RaritetnuWioN
09.03.2023 19:18
Алгоритм

Суть алгоритма заключается в том, что робот проверяет, нет ли стены справа, и если её нет, то выполняет следующее:

делает шаг вправо;закрашивает клетку, в которой находится;делает шаг вправо.Движение

Исходя из данного алгоритма, робот закрасит клетки, отмеченные на прикреплённом изображении.

Распишем выполнение алгоритма более детально:

(я пронумеровал клетки, чтобы было легче понять процесс)

(вместо "клетка ..." буду писать "К...")

справа свободно: робот из К1 перемещается в К2, закрашивает К2 (1) и перемещается в К3.справа свободно: робот перемещается в К4, закрашивает К4 (2) и перемещается в К5.справа свободно: робот перемещается в К6, закрашивает К6 (3) и перемещается в К7.справа свободно: робот перемещается в К8, закрашивает К8 (4) и перемещается в К9.справа не свободно: цикл больше не выполняется.

ответ: 4.


Сколько клеток закрасит Робот, выполнив такой алгоритм? Стартовая позиция Робота на рисунке обозначе
0,0(0 оценок)
Ответ:
DashaL109
DashaL109
13.03.2020 15:43

2³ = 3 + 5

3³ = 7 + 9 + 11

4³ = 13 + 15 + 17 + 19

Заметим что во втором выражении первое число(7) получается как 3*(3-2)+1

В третьем аналогично: 13 получается как 4*(4-1)+1

Получаем формулу для первого значения: x1 = n*(n-1)+1

Остальные числа получаются путём прибавления 2 к предыдущему слагаемому. Так же заметим что число слагаемых равно числу которое мы возводим в степень.

x = int(input("Введите число: "))

xn = x * (x - 1) + 1  

rezultat = xn  

while (x != 1):

   xn += 2

   rezultat += xn

   x -= 1

 

print("Результат возведения в 3 степень:", rezultat)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота