Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
moyutot
09.04.2022 04:43 •
Информатика
Задан массив x[1..n]. определите число операций сложения, которые выполняются при работе этой программы: s: =x[1]+x[n]+3; for k: =1 to n do for m: =1 to n do x[k]: =x[k]+s; , если можно с подробным объяснением
Показать ответ
Ответ:
ZeBrAiL2TW
11.09.2021 14:24
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0
(0 оценок)
Ответ:
arada1
23.10.2022 06:31
//я писал этот унылый код полтора часа. Полтора часа, Карл! Я слишком расслабился.
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Anastasia20181
06.01.2023 00:48
Разгадайте ребус ответ на украинском языке...
rbaimova
31.03.2021 14:28
Как сделать скриншот на пк...
soos4
12.01.2021 23:29
В кодировке Unicode на каждый символ отводится два байта. Определи информационный объём текста из 55 символов в этой кодировке. ответ: байтов....
zlu4ka11
23.02.2022 03:38
Для чего нужна геперссылка...
AlinkaMalinka233
02.10.2020 21:08
Составить программу вычисления площади треугольника...
18000000
14.03.2023 20:55
Скажите как растения и животные информацию друг надо...
Licona
06.01.2020 04:59
Напишите программу, определяющую, сколько в классе людей с самым высоким ростом (естественно, у них у всех он технические условия входные данные – количество n учеников...
Катикини
10.09.2021 18:43
Военное дело монголо-татар. можете написать доклад,найти,а то никак не могу...
MoonVar
20.05.2020 03:47
Расположение,уклониться,подростать,касательная,наклон,угар,заросли,клоняться,выгореть,прикасаться,склониться,предложение,наклоняться,водоросли,загорать,растение,отклонение,коснуться,вырос,догарать,касание,подгореть,выращивать,поклонение,сгореть,отраслевой,приложение....
Sandra2516
20.05.2020 03:47
Что такое медиана треугольника? что такое высота треугольника? что такое перпендикуляр?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}