В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kokosik23
kokosik23
30.08.2020 16:27 •  Информатика

Задан вектор p. напишите программу вычисления отношения произведения положительных элементов вектора к сумме элементов, больших арифметического среднего всех значений. решите в паскале

Показать ответ
Ответ:
sashaloxas
sashaloxas
08.05.2023 04:48
While (tnum != 0)  //tnum, tden - числитель и знаменатель искомой                                    дроби
    {
        if (tnum < tden)
        {
            temp = tnum;
            tnum = tden;
            tden = temp;
        }
        tnum = tnum - tden;
    }
    gcd = tden;  //вычисляем наибольший общий делитель
    numerator = numerator / gcd;  //делим числитель и знаменатель на
                                                      НОД, получаем сокращенную дробь
    denominator = denominator / gcd;
0,0(0 оценок)
Ответ:
66vdv1
66vdv1
16.04.2021 06:15
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
 then writeln('Не квадратное уравнение!')
 else begin
      d:= sqr(b)-4*a*c;
      if d < 0 then writeln('Нет корней')
               else begin
                    x1:= (-b+sqrt(d))/2*a;
                    x2:= (-b-sqrt(d))/2*a;
                    writeln ('X1 =',x1,'  X2 =',x2);
                    end;
      end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота