Задание 2. Николай решил написать программу для решения уравнения x-2b=a (a и b задаются с клавиатуры)
A. Составьте алгоритм решения данного уравнения
B. Составьте блок схему для решения уравнения x-2b=a
[2]
Задание 3. Азату дали задание написать программу нахождения квадратов чисел в диапазоне от a до b (a и b задаются с клавиатуры). Укажите, какую алгоритмическую конструкцию необходимо использовать для решения этой задачи?
[1]
Задание 4. По данной блок –схеме дополните псевдокод недостающими командами в теле цикла.
алг сумма
вещ a,s
нач
S:=0;
A:=1;
нц
1.
2.
3.
кц
вывод S
кон заранее ОГРОМНОЕ
var
c, a: array[1..20] of integer;
i: integer;
begin
write('Первый массив ');
for i := 1 to 20 do begin
c[i] := i * (-5);
write(c[i], ' ');
end;
writeln;
write('Преобразованный массив ');
for i := 1 to 20 do begin
a[i] := c[20 - i + 1];
write(a[i], ' ');
end;
end.
ИЛИ Программа не использующая два массива, а просто переворачивающая первый
var
c: array[1..20] of integer;
i: integer;
begin write('Первый массив ');
for i := 1 to 20 do begin
c[i] := i * (-5);
write(c[i], ' ');
end;
writeln;
write('Преобразованный массив ');
for i := 20 downto 1 do write(c[i], ' ');
end.
Обе программы работают!
если вам надо перевести его в какую-нибудь систему счисления, то нужно делить это число на номер системы, так если нужно перевести число 137 в ДВОичную ,то делим на 2 до тех пор, пока остатотк от деления не равен 1.(если в ТРОичную то на 3 и т.д.).
начнём:
137 / 2 = 68 выписываем остаток (1)
68 / 2 = 34 выписываем остаток (0)
34 / 2 = 17 выписываем остаток (0)
17 / 2 = 8 выписываем остаток (1)
8 / 2 = 4 выписываем остаток (0)
4 / 2 = 2 выписываем остаток (0)
2 / 2 = 1 <== на этой единице заканчиваем деление, далее снизу вверх выписываем получившееся число : 001001;
ответ: 001001