В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
marialkahelp
marialkahelp
22.04.2022 23:19 •  Информатика

Задание на языке Паскаль: написать программу для вычисления значения переменной Y при условии, если Х> 2, то Y = 2Х, иначе Y = Х + 5. Использовать условный оператор If ...Then ...Else ..

Показать ответ
Ответ:
Mashannjjj
Mashannjjj
11.09.2020 21:16

Variant 1

begin

 var x := ReadInteger('Введите X:= ');

 if x > 2 then

   Println('Y:= ', 2 * x)

 else

   Println('Y:= ', x + 5);

end.

Varian 2

var

 x, y: integer;

begin

Writeln('Введите Х: ');

 Read(x);

 if x > 2 then

 begin

   y := 2 * x;

 end

 else

   y := x + 5;

 Write(y);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота