В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
dasausakova526
dasausakova526
27.04.2022 03:31 •  Информатика

1)дан одномерный массив. найти сумму элементов принадлежащих промежутку от а до в (а и в вводятся с клавиатуры) 2)одномерный массив заполнить n случайными целыми числами находящимися в интервале от 0 до 15. найти произведение максимального и минимального элемента массива. вывести массив, числа должны распологатся в строке. 3)составить программу используя оператор while вывести на экран , кратные к из промежутка (а,в). числа к,а,в задаёт пользователь 4)составить программу используя оператор for дана последовательность из n целых чисел. определить произведение элементов этой последовательности

Показать ответ
Ответ:
alisiakuzmur
alisiakuzmur
07.09.2020 23:01
1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100); {Заполняем массив случайными числами в промежетке от 0 до 99 (можешь изменить промежуток}

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then sum:=sum+mas[i]; end; Writeln(sum); end.    2)  Program massiv; Var mas:array[1..20] of integer; i,min,max,pr:integer; Begin For i:=1 To 20 Do begin mas[i]:= random(15); write(mas[i],' '); end; Writeln; min:=30000; max:=0; For i:=1 To 15 Do begin if mas[i]>max Then max:=mas[i]; if mas[i]<min Then min:=mas[i]; end; pr:=min*max; Writeln(pr); end.  3)Program massiv;Var mas:array[1..20] of integer; a,b,i,k:integer;BeginFor i:=1 To 20 Dobegin mas[i]:= random(100); {Заполняем массив случайными числами в промежетке от 0 до 99 (можешь изменить промежуток}write(mas[i],' ');end;Writeln('Введите a,b,k');Readln(a,b,k);i:=1;While i<>20 Dobeginif (mas[i]>a) and (mas[i]<b) and(mas[i] mod k=0) ThenWrite(mas[i],' ');i:=i+1;end; end. 4)Var mas:array[1..20] of integer; i,min,max,pr:integer; Begin randomize; For i:=1 To 20 Do begin mas[i]:= random(100)+1; write(mas[i],' '); end; Writeln; pr:=1; For i:=1 To 15 Do begin pr:=pr*mas[i]; end; Writeln(pr); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота