В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
katia6747
katia6747
19.05.2021 12:59 •  Информатика

1. написать программу которая ищет n! (цикл while)2. написать программу, которая находит число р = (1-1/2)(1-1/3)**(1-1/n). n вводится с клавиатуры. (цикл for)

Показать ответ
Ответ:
oldespower
oldespower
29.05.2020 12:06

Объяснение:

1.

var

 k:integer;

 p:integer;

 n:integer;

begin

 readln(n);

 

 p:=1;

 k:=1;

 

 while (k <= n) do begin

   p:=p*k;

   k:=k+1;

 end;

 

 writeln(p);

 

end.

2.

var

 k:integer;

 p:real;

 n:integer;

begin

 readln(n);

 

 p:=1;

 

 for k:=2 to n do begin

   p:=p*(1 - (1/k));

 end;

 

 writeln(p);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота