25. Напишите программу, которая ищет среди целых чисел, принадлежа- щих числовому отрезку (100 000; 250 000), числа, которые можно предста-
вить в виде произведения не менее 4 подряд идущих натуральных чисел,
ни одно из которых не равно 1. Для каждого найденного числа запишите
в таблицу на экране числа в следующем порядке: число, представимое в
виде произведения, наименьший множитель в произведении, наибольший
множитель в произведении.
Если знаете С++, по на этом языке
from itertools import product
i = open('input.txt', 'r')
o = open('output.txt', 'w+')
l = int(i.
alpha = "245"
d = []
for s in product(alpha, repeat=l):
d.append([" ".join(
for q in d[1: ]:
s = " ".join(q)
if int(s.count('2')) > 2:
continue
o.write(" ".join(q) + '\n')
i.close()
o.close()
код к : «перевод кода с питона на паскаль»
var
n,c,i,ost,b,t,d: integer;
a,k: string;
begin
readln(n);
c: =1;
for i: =1 to n do
c: =c*3;
c: =c-1;
for i: =1 to c do
begin
k: ='';
b: =i;
t: =0;
while b> 0 do
begin
ost: =b mod 3;
if ost=0 then inc(t);
d: =(-sqr(ost)+5*ost+4)div 2;
str(d,a);
k: =a+k;
b: =b div 3;
end;
while length(k)do
begin
k: ='2'+k;
inc(t);
end;
if t< =2 then writeln(k);
end;
end.