В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
McКлей
McКлей
15.03.2021 14:11 •  Информатика

даю Задача по информатике на Python:

Алекс получил от своего друга Никиты из России электронное письмо с вложенным текстовым файлом (не маленьким – точно больше 100Кб) и был удивлен его содержимым. Алекс давно знаком с Никитой и знает, что текст точно на русском языке, что он все пишет в нижнем регистре, и что Никита принципиально не использует никакие кодировки, кроме однобайтовых.
Алекс хотел бы определить, какую кодировку Никита использовал (CP866 (DOS), CP1251 (Windows), KOI8R, ISO-8859-5, cp10007(MacOS)), и увидеть первые 2048 символов этого файла в кодировке UTF-8.

Воспользуйтесь имеющимися данными, напишите программу, которая введет с клавиатуры имя файла, автоматически определит его кодировку и выведет первые 2048 символов этого файла в кодировке UTF-8 на экран.

Обратите внимание: все данные для работы программы поступают из стандартного потока ввода (в Python используется функция input() ), каждый параметр - отдельной строкой. Все результаты выводятся в стандартный поток вывода ( в Python используется функция учтите, что весь вывод программы будет сравниваться с ответом, не выводите лишние комментарии.

Показать ответ
Ответ:
Ljshegsyweee
Ljshegsyweee
20.04.2021 16:18

не так уж и трудно, если

program project2;

var

n,a,b,c,i,k,max,min: longint;

inp,outp: text;

begin

assign(inp,'input.txt');

reset(inp);

assign(outp,'output.txt');

rewrite(outp);

readln(inp,n);

max: =0;

min: =0;

c: =0;

for i: =1 to n do

begin

read(f1,a);

if i=1 then

b: =a;

if a> max then

max: =a;

k: =a-c;

c: =a;

if k< 0 then

begin

k: =abs(k);

min: =min+k;

if k> min then

min: =k;

end;

end;

max: =max-b;

write(outp,max,' ',min);

close(inp);

close(outp);

end.

0,0(0 оценок)
Ответ:
55752188
55752188
29.01.2023 17:22

рассмотрим выражение x< 5. оно истинно для всех ответов рассмотрим выражение x< 3. оно истинно для 1, 2 и ложно для 3, 4 рассмотрим первую импликацию: две истины истину, значит для ответов 1,2 вторую импликацию (после или) можно не рассматривать, поскольку первая часть истинна.для вариантов 3,4 рассмотрим вторую импликацию.выражения x< 2 и x< 1 для вариантов 3,4 ложь. импликация, где оба аргумента ложь, истинна. получается, что для ответов 3,4 истинна вторая импликация, а значит значение первой несущественно (для оператора или).отсюда следует, что выражение "((x  <   5)→(x  <   3))  или  ((x  <   2)→(x  <   1))" истинно при всех перечисленных значениях х: 1, 2, 3, 4

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота