В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Anna111864
Anna111864
02.08.2020 11:50 •  Информатика

Девчата, тут такое затруднение. нужна программа в паскале, только в паскале. условие: напишите программу которая вычисляет среднее арифметическое элементов таблицы а(3*8) . программа по двумерным массивам.

Показать ответ
Ответ:
horarharry
horarharry
10.07.2020 21:29
Uses crt;
var i,j,k,ni,nj:integer; a:array[1..100,1..100] of integer;
begin
clrscr;
randomize;
ni:=3; nj:=8;
for i:=1 to nj do begin
for j:=1 to ni do
a[i,j]:=random(10);
end;
for i:=1 to nj do begin
for j:=1 to ni do
write(a[i,j],' ' ); writeln;
end;
for i:=1 to nj do begin
for j:=1 to ni do
k:=k+a[i,j];
end;
writeln('sr = ',k);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота