Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
Miratrix
29.03.2023 16:11 •
Информатика
На паскале 1.найти сумму первых 10 натуральных нечетных чисел. 2.найти произведение натуральных чисел прекратить подсчет при вводе 1.
Показать ответ
Ответ:
полинаполига
01.10.2020 22:16
Var
a,b,c,d:integer;
begin
c:=1;
b:=0;
while a<>1 do begin
readln(a);
if a mod 2 <> 0 then begin
b:=b+1;
if b<=10 then c:=c+a;
end;
c:=c*a;
end;
writeln(b,' ',c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
паст145
02.10.2021 21:10
Вpascal abc cреди первых двадцати членов последовательности xn=sin(πn/17) + cos(πn/12) найти номер первого отрицательного члена....
galeevaazaliyaqwert
26.05.2023 01:06
При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы а, б, в, г, д, е. каждый такой пароль в...
Дашанеси
07.02.2021 15:03
Напишите код, , в pascal вообще не разбираюсь...
sauleshka3
20.01.2021 20:11
Напишите программу, которая вводит с клавиатуры пятизначное число и удаляет из него первую и последнюю цифру, а затем выводит на экран полученное трехзначное число. например,...
ksenia1234567890123
08.11.2022 14:27
Написать код в с++: задан массив из k чисел. сдвинуть элементы массива циклически на n позиций вправо....
planeta88
22.08.2021 17:22
Водномерном массиве, состоящем из n (не более 10) вводимых с клавиатуры значений, вычислить cумму элементов массива, расположенных до последнего положительного элемента....
bayrzhan
31.10.2020 23:57
Надёжность паролей. Урок 2 Вставь пропущенные слова.используется для внесения прав доступа, что позволяет защитить файл от редактирования и печати, при этом пользователи...
Maks23241
15.04.2021 02:13
На экран выведено содержимое папки ball ball.exe 35600 10.05.10 10: 30 ball.txt 2050 15.05.10 18: 50 ball.rez 1700 25.09.12 14: 25 какую информацию о файле ball.exe можно...
гэлочка
15.04.2021 02:13
Валфавите 4 буквы каждая выпадает с вероятностью 0,4 0,3 0,2 0,1. найти общий объем информации...
VitaKoroleva851
12.03.2023 17:44
Местоимение он это самостоятельная часть речи?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a,b,c,d:integer;
begin
c:=1;
b:=0;
while a<>1 do begin
readln(a);
if a mod 2 <> 0 then begin
b:=b+1;
if b<=10 then c:=c+a;
end;
c:=c*a;
end;
writeln(b,' ',c);
end.