В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Написать программу для решения следующей : вычислить сумму и количество положительных элементов последовательности.

Показать ответ
Ответ:
Евгеха001
Евгеха001
01.10.2020 12:22
Var
  sum, count, t : integer;
begin
  sum := 0; count := 0;
  while not eoln do
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.

если количество элементов указано
var
  sum, count, t, n, i : integer;
begin
  sum := 0; count := 0;
  read (n);
  for i := 1 to n do 
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота