Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
TigerTanya
31.03.2021 07:52 •
Информатика
написать программу для вычисления площади треугольника, если известна длина его двух сторон и величина угла между ними написать программу на С++
Показать ответ
Ответ:
Диханбаев
15.10.2020 21:13
С++17
Код:
#include <iostream>#include <cmath>double triangle_space(double a, double b, double angle) { return 0.5 * a * b * sin(angle);}int main() { double a, b, angle; std::cin >> a >> b >> angle; std::cout << triangle_space(a, b, angle) << std::endl;}
0,0
(0 оценок)
Популярные вопросы: Информатика
lizaivleva201
13.03.2020 02:26
1. Запустите Excel. 2. Лист 1 рабочей книги назовите Данные значений. В столбец С введите числовую арифметическую последовательность по варианту (вариант из табл.6) 61 Таблица...
Wolfie2006
08.08.2021 23:06
на координатной плоскости задано 100 случайных точек, дана окружность с центром в начале координат. Найти количество точек, лежащих внутри окружности в первой четверти и количество...
irca1987
12.04.2023 03:22
В приведенном ниже тексте выделите объект ( с точки зре ния объектно - информационного моделирования ) и укажи те его свойства . Файл ( англ . file ) — именованная область данных...
MagicalBiology
07.03.2021 03:28
Разгадайте кроссворд по информатике. ...
AkvaH2O
14.08.2020 01:47
Написать программу с#: Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3) своих вершин. Вычислить радиус окружности, вписанной в треугольник...
Натаван11082004
14.04.2022 09:25
Нужно изменить один пункт в правой колонке (право допустим на лево) что бы дойти до зайца...
oksiur4enko
21.09.2021 14:23
Вывод 91 элементов массива С в строку (параметром цикла является переменная W.нумерация начинается с 1)паскаль...
supermax18
10.06.2021 00:40
Какие виды физических развивают 2 вида бега.чем марафон отличается от спринта?...
KINDER123567
25.06.2021 21:06
Алые паруса синквейн Служанка Грея и Отец Ассоли Даю 10В...
strakh1991
26.03.2021 16:40
638. Найдите значения остальных тригонометрических функций, если известно, что:б) сos a = 5/15 и 3п/2 a 2п очень где 5/15 и 3п/2 - это дробь...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
С++17
Код:
#include <iostream>#include <cmath>double triangle_space(double a, double b, double angle) { return 0.5 * a * b * sin(angle);}int main() { double a, b, angle; std::cin >> a >> b >> angle; std::cout << triangle_space(a, b, angle) << std::endl;}