В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
UTOYKA228
UTOYKA228
23.02.2023 13:19 •  Информатика

Написать программу, которая находит одинаковые цифры двух чисел. в pascal, желательно через function. можно чтобы токого не было.входные данные: 466 476. выходные : 6 6. заранее

Показать ответ
Ответ:
Astento
Astento
16.08.2020 21:02
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

function Duplicates(a,b:int64):array of char;
begin
  var ha:=a.ToString.ToHashSet;
  ha.IntersectWith(b.ToString.ToHashSet);
  Result:=ha.ToArray
end;  

begin
  var m,n:int64;
  Write('Введите через пробел два натуральных числа: ');
  Read(m,n);
  var r:=Duplicates(m,n);
  if r.Length=0 then Writeln('Нет цифр, встречающихся в обоих числах')
  else r.Println(',')
end.

Примеры
Введите через пробел два натуральных числа: 12345 6789067
Нет цифр, встречающихся в обоих числах

Введите через пробел два натуральных числа: 1342103 6748644
4

Реализация без множеств

procedure nToArray(n:int64; a:array of boolean);
begin
  for var i:=0 to 9 do a[i]:=False;
  if n=0 then a[0]:=True
  else
    while n>0 do begin
      a[n mod 10]:=True;
      n:=n div 10
      end
end;

function Duplicates(a,b:int64):array of boolean;
begin
  var ma:=new boolean[10];
  var mb:=new boolean[10];
  nToArray(a,ma);
  nToArray(b,mb);
  Result:=new boolean[10];
  for var i:=0 to 9 do
    Result[i]:=ma[i] and mb[i]
end; 

begin
  var m,n:int64;
  Write('Введите через пробел два натуральных числа: ');
  Read(m,n);
  var r:=Duplicates(m,n);
  Write('Совпадающие цифры: ');
  for var i:=0 to 9 do
    if r[i] then Write(i,' ');
  Writeln
end.

Пример
Введите через пробел два натуральных числа: 12352423 98789635233
Совпадающие цифры: 2 3 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота