В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Написать программу которая сортирует одномерный массив "методом простого выбора" в порядке возрастания на с++

Показать ответ
Ответ:
sidorova123441
sidorova123441
10.10.2020 13:20

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int n;

   cin >> n;

   int a[n];

   srand(time(0));

   for(int i=0; i<n; i++)

   {

       a[i]=-99+rand()%199;

       cout << setw(4) <<a[i];

   }

   cout << endl;

   int j=n-1;

   while(j>0)

   {

       int mx=a[0], imx=0;

       for(int i=1; i<=j; i++)

           if(a[i]>mx)

           {

               mx=a[i];

               imx=i;

           }

       a[imx]=a[j];

       a[j]=mx;

       j--;

   }    

   for(int i=0; i<n; i++)

       cout << setw(4) <<a[i];

    return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота