В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
1AnGor1
1AnGor1
09.04.2022 04:55 •  Информатика

Написать программу на paskal(lazarus)
написать программу нахождения корня уравнения методом простых итераций и методом половинного деления. нужно написать программу без функций. )

Показать ответ
Ответ:
poshova002
poshova002
09.02.2020 13:29

1)Что такое поле БД?  (ответ) Поле базы данных - это столбец таблицы, содержащий значения определенного свойства. Строки таблицы являются записями об объекте; эти записи разбиты на поля столбцами таблицы, поэтому каждая запись представляет собой набор значений, содержащихся в полях.

2) Для чего нужно связывать таблицы в БД?

(ответ) Многие СУБД при связывании таблиц автоматически выполняют контроль целостности вводимых в базу данных в соответствии с установленными связями. В конечном итоге это повышает достоверность хранимой в БД информации.

3)  Что такое База данных? (ответ) представленная в объективной форме совокупность самостоятельных материалов, систематизированных таким образом, чтобы эти материалы могли быть найдены и обработаны с электронной вычислительной машины

4)В каком режиме могут создаваться поля БД?

(ответ)

*создание таблицы в режиме конструктора;

*создание таблицы с мастера;

*создание таблицы путем ввода данных

5)  Если между таблицами БД установлены связи, то к чему может привести  изменение или удаление существующих полей? (ответ) Каждая запись в таблице "Сведения о заказах" содержит значение поля "КодТовара", которому соответствует запись в таблице "Товары" с тем же значением в данном поле. тут не уверен честно

6) Что такое ключевое поле БД?  (ответ)Ключевое поле — это одно или несколько полей, комбинация значений которых однозначно определяет каждую запись в таблице. Если для таблицы определены ключевые поля, то Microsoft Access предотвращает дублирование или ввод пустых значений в ключевое поле.

7) Назовите два основных этапа создания БД (ответ) Определить структуру базы данных и типа каждого поля. 2. Ввод данных. ... Поиск информации в базе данных на основе критериев поиска

8)При чего можно создать формы ввода данных в таблицу

(ответ)

инструмента Form;

инструмента Разделенная form;

инструмента Несколько элементов;

инструмента Пустая form;

Мастера form;

Конструктора form.

9)Приведите примеры типов полей (из разобранного видеоматериала)

(ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

10)Приведите примеры типов полей из разобранного видеоматериала (ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

11)Опишите тип поля счетчик своими словами (ответ) новое поле предназначенное для хранения часто изменяющихся целочисленных данных

12)Из каких файлов можно импортировать данные в таблицу БД? (ответ) импортировать таблицы, за формы, отчеты, макросы и модули из одной базы данных Access в другую. При импорте Access создает копию объекта в текущей базе данных.

(вроде всё!)

0,0(0 оценок)
Ответ:
Artem574189
Artem574189
14.03.2022 00:28

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "");

int N = 10;

int max = -9999999;

int sum = 0;

int choise = 0;

int arr[N] = {0};

cout << "Введите 10 значений: ";

for(int i = 0; i<N; ++i) {

cin >> arr[i];

}

cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";

cin >> choise;

if(choise==1) {

for(int i = 0; i<N; ++i) {

sum+=arr[i];

}

cout << endl << "Сумма: " << sum;

}

if(choise==2) {

for(int i = 0; i<N; ++i) {

if(arr[i]>max) {

max = arr[i];

}

}

 cout << endl << "Макс. знач: " << max;

}

if(choise==3) {

 for(int i = 0; i<N; ++i) {

   if(arr[i]<0) {

     ++sum;

   }

 }

 cout << "Колво отр. знач: " << sum;

}

 if(choise!=1&&choise!=2&&choise!=3) {

   cout << "Введите корректное значение.";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота