Написать программу на питон Как известно, дети часто не любят делиться игрушками. Особенно сложно дела с игрушками обстоят одной в семье, в которой n детей. Пока игрушки равномерно были разложены на полу, каждый ребенок начертил мелом на полу прямоугольник со сторонами, параллельными стенам комнаты, и объявил, что он будет играть в игрушки, лежащие в его прямоугольнике. Поскольку за честностью деления никто не следил, то получившиеся прямоугольники были разных размеров, пересекались и накладывались друг на друга. Поэтому в какой-то момент детям стало интересно, в какой области комнаты они могут играть все вместе одновременно. Входные данные В первой строке ввода задано число n — количество детей, и, соответственно, прямоугольных областей на полу (1⩽n⩽2⋅105). В каждой из следующих n строк дана информация о соответствующем прямоугольнике — четверка чисел x1, y1, x2, y2, первые два из которых задают координаты левого нижнего угла, а вторые — правого верхнего, если смотреть на комнату сверху (−109⩽x1
{ Организует ввод и возвращает значения роста и веса.
Значение параметра Final=true - сигнал окончить ввод данных,
для чего вводят нули }
begin
Write('Введите рост (см) и вес (кг) ->');
Readln(r, v);
Final := ((r > 0) and (v > 0))
end;
function DefDesk(r: real): string;
begin
if r <= 140 then DefDesk := 'S'
else if r < 150 then DefDesk := 'M'
else DefDesk := 'L'
end;
var
rost, ves: real;
flag: boolean;
begin
repeat
GetRV(rost, ves, flag);
if flag then Writeln('Нужна парта типа ', DefDesk(rost))
until (not flag)
end.
Тестовое решение:
Введите рост (см) и вес (кг) ->135 31
Нужна парта типа S
Введите рост (см) и вес (кг) ->143 41
Нужна парта типа M
Введите рост (см) и вес (кг) ->151 48
Нужна парта типа L
Введите рост (см) и вес (кг) ->0 0
0.85Е2 =85
-5.7Е-3 = -0.0057
0.1Е4=1000
Что будет выведено на экран после выполнения следующих команд:
a-435c
c= 35.1b= -435 280.126-435
Вычислить значения выражений:
Round(frac(6.9)); = 1
20 mod 6 * 3; = 6
sqrt(trunc(0.5)) = 0
Записать выражения в общепринятой форме:
(-3ab+(b-4*a*c)^2)/корень(2*a);
(корень(|a-b|)*(a+b)^2.
a) y:= y * 2; правильная. операция возможна для вещественных чисел.
в) х:= х mod 3 + х*cos(0); правильная, все опрации подходят для целых чисел
б) x:=trunc(y); правильная
г) x:= y+1. неверно нельзя преобразовать вещественный тип в целый