В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
jasmin20052
jasmin20052
21.03.2020 02:40 •  Информатика

Написать программу на яп паскаль для вычисления площади треугольника по его сторонам ab, bc, ca (формула герона). программу написать на 13 строк.

Показать ответ
Ответ:
dzyadukh1
dzyadukh1
09.10.2020 10:13

//PASCAL ABC.NET

var

 s, p, ab, bc, ca: real;

begin

 read(ab, bc, ca);

 p := (ab + bc + ca) / 2;

 s := sqrt(p * (p - ab) * (p - bc) * (p - ca));

 writeln(p, #10, s);

end.


 

0,0(0 оценок)
Ответ:
italyyyy
italyyyy
09.10.2020 10:13

Ровно 13 строк:

program Geron;

var ab,bc,ca,p: real;

begin

writeln('Определение площади треугольника по теореме Герона');

write('Введите сторону треугольника AB: ');

readln(ab);

write('Введите сторону треугольника BC: ');

readln(bc);

write('Введите сторону треугольника CA: ');

readln(ca);

p:=(ab+bc+ca)/2;

writeln('Площадь треугольника равна ',sqrt(p*(p-ab)*(p-bc)*(p-ca)):0:3)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота