В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Ganshit
Ganshit
13.05.2020 09:43 •  Информатика

Написать программу с использованием условного оператора, условной операции, оператора switch (на выбор один из ) определяющее расположение точки А (х,у)
относительно заштрихованной области.


Написать программу с использованием условного оператора, условной операции, оператора switch (на выб

Показать ответ
Ответ:
goloshapov145
goloshapov145
29.04.2021 01:58

В таблице типа «объект-свойство» одна строка содержит информацию об одном объекте. Столбцы - отдельные характеристики (свойства) объектов. (Например каталог книг: в строках объекты - книги; в столбцах их свойства - автор, название, год выпуска и т.п.).

В таблице типа «объект-объект» отражается взаимосвязь между различными объектами. (Например таблица успеваемости: в строках объекты - ученики; в столбцах объекты - учебные дисциплины; цифры на пересечении строк и столбцов показывают их взаимосвязь - полученные оценки.)

0,0(0 оценок)
Ответ:
Kristia03
Kristia03
29.12.2022 21:41
Var
  n, k, t, i, counter, j: int64;
  c: array[1..10]of int64;
  a: array[1..100000]of int64;
  ar: array[1..10, 1..100000]of int64;
  count: array[1..10]of int64;
  b: boolean;

 label l1;

  begin
  b := true;
  counter := 0;
  read(n, k, t);
  for i := 1 to n do read(c[i]);
  for i := 1 to k do read(a[i]);
  l1:
  while (counter <> k) do
   begin
    for j := 1 to n do
     begin
      for i := 1 to c[j] do
       begin
        if(ar[j, i] <= a[counter + 1]) then
         begin
          ar[j, i] := t + a[counter + 1];
           counter := counter + 1;
          count[j] := count[j] + 1;
          b := false;
          goto l1;
        end;
      end;
    end;
    if(b = true) then counter := counter + 1;
    b := true;
  end;
  for i := 1 to n do write(count[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота