В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
1LOSI1
1LOSI1
26.10.2020 10:42 •  Информатика

Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.

Показать ответ
Ответ:
limon4ikru
limon4ikru
02.10.2020 08:30
Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)

var  a: integer;
begin
  read(a); 
 if (a > 5) and (a <= 11) then
    write('Утро ');
 if (a > 11) and (a <= 17) then
    write('День ');
 if (a > 17) and (a <= 23) then
    write('Вечер'); 
 if (a = 24) or (a < 6) then 
    write('Ночь');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота