В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
лунтик56
лунтик56
24.06.2020 02:30 •  Информатика

Напишите программу вычисления наименьшего общего кратного следующих четырёх чисел: 36 54 18 и 15. используйте процедуру вычисления наибольшего общего делителя двух чисел. информатика 9 класс

Показать ответ
Ответ:
marmakmp
marmakmp
01.09.2020 14:47
// НОД(a,b)*НОК(a,b)=a*b
procedure nod(x,y: integer; var n: integer);
begin
    repeat
        if x>y then x:=x mod y
        else y:=y mod x;
    until (x=0)or(y=0);
n:=x+y;
end;
var a,b,c,d,e,n: integer;
begin
readln(a,b,c,d);
nod(a,b,n);
e:=a*b div n;
nod(c,e,n);
e:=c*e div n;
nod(d,e,n);
Writeln('НОК = ',d*e div n);
end.

Пример:
36 54 18 15
НОК = 540
Напишите программу вычисления наименьшего общего кратного следующих четырёх чисел: 36 54 18 и 15. ис
0,0(0 оценок)
Ответ:
vyzgavalja1956
vyzgavalja1956
01.09.2020 14:47
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018//Внимание! Если программа не работает, обновите версию!

procedure nod ( a,b: integer; var h: integer);

    var c: integer;

    begin

        repeat

            if a > b then

                a := a mod b

            else

                b := b mod a;

        until (a = 0) or (b = 0);         h := a + b;

    end;begin

var (a,b):=readinteger2('a,b->'); var h:integer;

nod(a,b,h);

Writeln('НОК',a*b/h);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота