В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Ludo4ka123
Ludo4ka123
30.09.2022 21:45 •  Информатика

Paskal 1) написать программу с циклом. дана переменная "n", написать программу где все значения "n" будут суммироваться пока n не будет равно 1 2) написать программу с циклом. дана переменная e, нужно выводить "e" в квадрат до тех пор пока "e" не будет равно 100 program test; var.. begin

Показать ответ
Ответ:
Nurana15
Nurana15
25.06.2020 19:59
Var
    i, n, s: integer;

begin
    read(n);
    for i := n downto 1 do
        s := s + i;
    writeln(s);
end.

2)
var
    i, e: integer;

begin
    write('e = ');
    readln(e);
   
    if e > 100 then
        for i := e downto 100 do
            writeln(i * i)
    else
        for i := e to 100 do
            writeln(i * i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота