Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
dashok32
31.10.2021 15:43 •
Информатика
Паскаль. дана строка n символов. вывести все слова с удвоенными буквами
Показать ответ
Ответ:
mokhovayaarina
07.07.2020 19:26
Var
n,i:integer;
s,t:string;
f:boolean;
begin
readln(s);
n:=length(s);
f:=false;
for i:=2 to n do
begin
t:=t+s[i];
if s[i]=s[i-1] then f:=true;
if (s[i]=' ') or (i=n) then
begin
if f then writeln(t);
t:='';
f:=false;
end
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vhjklv
28.03.2023 21:51
Сколько существует различных символьных последовательностей длины 5 в трехбуквенном алфавите к о т , которые содержат ровно две буквы о....
arsaeva73
23.03.2022 05:27
Хранящейся в этой памяти информация воспроизводится даст быстро...
рома1340
23.03.2022 05:27
Из непрозрачного мешочка вынимают шарики с номером,и известно,что информационное сообщение о номере шарика несёт 6 битов информации определить количество шариков...
mexoc
24.03.2021 04:02
Даны две цифры в десятичной системе счисления. напишите программу, которая выводит название на языке цифры модуля разности этих цифр...
kuzmina9999
04.09.2020 13:28
1. С клавиатуры вводятся координаты вершин треугольника АВС. Подсчитать длины его сторон и площадь. (Длину стороны треугольника можно вычислить по формуле: D=sqrt(sqr(x1-x2)+sqr(y1-y2)),...
Alievsergei
01.08.2021 07:46
Прочитайте текст. Объясните его название. Какие умения необходимы работнику образования ? Обоснуйте свое мнение. Законспектируйте последний абзац. Как слушать?...
Юлья0000000
10.02.2020 11:41
Наявність у хребті людини вигинів є пристосуванням до а)суспільного життя б)мислення і мови в)праці г)прямоходіння...
SofiaAM
02.06.2022 17:27
Найдите в интернете сайт любой промышленной фирмы например судостроительной фирмы Алмаз (http://almaz-kb.ru/company/partners/sudostroitelnaya-firma-almaz/). По...
nastponomarenk
06.07.2021 20:49
Що показує масштаб? 2. Які види масштабів розрізняють? 3. Як знайти відстань на місцевості за до масштабу? 4. Переведіть числовий масштаб в іменований 1:5000; 1:30;...
ivankamartynyk
13.01.2020 11:44
ПАМАГИТЕ После добавления в стакан с бесцветной прозрачной жидкостью нескольких капель фенолфталеина, жидкость в стакане приобрела малиновый цвет. Этой жидкостью...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n,i:integer;
s,t:string;
f:boolean;
begin
readln(s);
n:=length(s);
f:=false;
for i:=2 to n do
begin
t:=t+s[i];
if s[i]=s[i-1] then f:=true;
if (s[i]=' ') or (i=n) then
begin
if f then writeln(t);
t:='';
f:=false;
end
end;
end.