В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
VasilisaLisMUR
VasilisaLisMUR
25.09.2020 16:54 •  Информатика

PYTHON

Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8.
По введенным координатам двух полей (kl) и (mn) выясните, угрожает ли ферзь, находящийся на поле (kl) , полю (mn) ?

Входные данные
На вход программе подаются четыре целых числа klmn .

Выходные данные
Выведите YES или NO в зависимости от ответа на во задачи.

Показать ответ
Ответ:
TRIPLEN
TRIPLEN
26.01.2023 17:34
#include <iostream>
#include <cmath>
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
   double p = (a + b + c) / 2;
   return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main() 
{
   double a1, b1, c1, a2, b2, c2;
   cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;
   if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)
      cout << "YES";
   else
      cout << "NO";
}
0,0(0 оценок)
Ответ:
azalinasabirova
azalinasabirova
28.12.2021 07:24

Как я понял,нужно было вывести главную и побочную диагонали.

Ошибки:

пропущены скобки,как обычные так и фигурные;пропущены знаки ";","<" и т.д.;

Легче было заново написать чем исправлять.

Вот мой код:

import java.util.Scanner;

public class Main{

public static void main (String [] args){

 Scanner in = new Scanner (System.in);

 int n = in.nextInt();  

 int mass[][] = new int [n][n];

 int i,j;

 

 for(i=0;i<n;i++){

  for(j=0;j<n;j++){

   mass[i][j]=in.nextInt();

  }

 }

 

 for(i=0;i<n;i++){

  for(j=0;j<n;j++){

   if((i==j) || j==(n-1-i)){

    System.out.print("x");

   }else System.out.print(mass[i][j]);

   

  }

  System.out.println();

 }

 

 in.close();  

}

}

Объяснение:

Краткий алгоритм программы:Импортируем Scanner;Объявляем переменную in типа Scanner,для ввода;Объявляем переменную n типа int,для хранения размера массива;Объявляем две переменные i и j типа int,для циклов;В первом "двойном" цикле мы заполняем массив числами;Во втором "дойном" цикле мы мы сравниваем индексы массива и выводим результат;Закрываем Scanner;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота