Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
dianarudak
26.06.2021 10:58 •
Информатика
С++ как заполнить массив случайными вещественными ведь rand может возвращать только целые
Показать ответ
Ответ:
People200311
06.10.2020 06:43
Как соотношение выбранного и максимального случайного числа.
Код:
#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
int randFloatTo(float x)
{
float ret = static_cast <float> (rand()) / (static_cast <float> (RAND_MAX/x));
return ret;
}
int main()
{
srand(time(NULL));
int size;
cout << "Размер массива: ";
cin >> size;
cout << endl << "Массив:" << endl;
float arr[size];
for (int i = 0; i < size; i++) {
arr[i] = randFloatTo(rand());
cout << arr[i] << ' ';
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
shakutis
15.11.2021 05:00
Написати програму, що складається з двох списків Listbox. У першому буде перелік предметів зананий програмою. Другий список порожній, нехай це буде шкільне приладдя. Високий рівень...
McMamon
20.05.2020 10:52
напишите код к задаче: Для заданого цілого числа n знайти число, наступне за n, кратне 5....
Pacan4ikForever
22.01.2022 06:13
Написати програму, що складається з двох списків Listbox. У першому буде перелік предметів зананий програмою. Другий список порожній, нехай це буде шкільне приладдя....
sofiaivkina84
04.03.2021 16:28
1)Текст занимает на жестком диске 12 кбайт памяти и содержит 6144 символа, в какой кодировке представлен этот текст? 2) Электронная книга в 211 страниц, на странице в среднем 37...
likonady
13.01.2021 09:39
написать программу которая выводит эту последовательность 7 14 21 28 35 42 49 56 63 70 77 84 91 98 , используя цикл while...
dianababitskay
15.10.2021 23:05
Лабораторна робота №6 Тема: Знайомство з CSS. Знайомство із селекторами.Завдання:2. Створити файл стилів style.css. Створити HTML-документ task1.html та підключити у ньому style.css....
Yurianvinokurov
10.03.2023 08:06
Який рядок S буде сформовано у результаті виконання фрагмента програми? For i := 0 to 1 do For j := 0 to 1 do S:= S+ IntToStr (i) + IntToStr (j) ;...
Kazudon
12.01.2020 15:46
Переведите в двоичную систему счисления 8e...
ksenia20062
03.05.2020 11:15
Есть 01 и их 8 штукнапример : 10010001сколько может быть таких чисел но чтобы они не совпатали...
geracim1
08.04.2021 14:48
Запишите значение переменной s, полученное в результате работы следующей программы. текст программы на трёх языках программирования. алгоритмический язык бейсик паскаль алг нач...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Код:
#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
int randFloatTo(float x)
{
float ret = static_cast <float> (rand()) / (static_cast <float> (RAND_MAX/x));
return ret;
}
int main()
{
srand(time(NULL));
int size;
cout << "Размер массива: ";
cin >> size;
cout << endl << "Массив:" << endl;
float arr[size];
for (int i = 0; i < size; i++) {
arr[i] = randFloatTo(rand());
cout << arr[i] << ' ';
}
return 0;
}