В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
05Adam05
05Adam05
19.03.2020 08:27 •  Информатика

Составить программу на языке Паскаль нахождение значения выражения: у=2*x+k. где х и к любые числа.

Показать ответ
Ответ:
ThreeDragons
ThreeDragons
07.01.2023 15:58

import java.io.BufferedReader;

import java.io.InputStreamReader;

public class NewClass {

   public static void main(String[] args) throws Exception {

   BufferedReader reader = new BufferedReader(new InputStreamReader(System.in)); //поток ввода данных

   int a = Integer.parseInt(reader.readLine()); //вводим первое число

   int b = Integer.parseInt(reader.readLine()); //вводим второе число

   int result = b; //результат

   //здесь цикл сложения второго числа

       for (int i = 1; i < a; i++) {

           result += b;

       }

       //выводим результат в консоль

       System.out.println("Ваш ответ: " + result);

       reader.close();

   }

}

Объяснение:

написано на Java, не уточнили на каком ЯП надо программу написать..

0,0(0 оценок)
Ответ:
ryure146
ryure146
22.04.2020 06:45

Var

  size: integer;

  counter: integer;

  mas: array of integer;

   

Begin  

  Write('Введите количество чисел в последовательности: ');

  Readln(size);

   

  if (size > 0) then

  begin

     Writeln();

     SetLength(mas, size);

     

     for var i := 0 to size - 1 do

     begin

        Write('Введите ', i + 1, ' число: ');

        Readln(mas[i]);

         

        if ((mas[i] mod 3 = 0) and (mas[i] mod 10 = 2)) then

           counter := counter + 1;

     end;

     

     Writeln();

     Writeln('ответ: ', counter);

  end

   

  else

     Writeln('Количество чисел должно быть больше нуля!');

   

End.


Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, крат
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота