В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Chicken10
Chicken10
01.02.2023 16:35 •  Информатика

Составьте программу вычисления в массиве a(n) суммы всех чисел кратных 7 в кумире​

Показать ответ
Ответ:
nataliinfp0co9o
nataliinfp0co9o
26.10.2021 12:13
#include <iostream>
#include <cstdlib>
#include <ctime>

int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));

int mass[5];
bool op;

printf("Заполнить массив самостоятельно? (1/0): ");
scanf("%d", &op);
for(int i = 0; i < 5; i++){
if(op){
printf("Введите %d-е число: ", i+1),
scanf("%d", &mass[i]);
}else mass[i] = (rand() % 200) - 100;
}
std::cout << std::endl;
int sm = 0;
for(int i = 0; i < 5; i++)
if(mass[i] < 0) printf("%d-й элемент отрицательный: %d\n", i+1, mass[i]), sm++;
if(!sm) printf("В массиве нет отрицательных чисел.");

return EXIT_SUCCESS;
}
0,0(0 оценок)
Ответ:
aknurrakhmanber
aknurrakhmanber
01.01.2022 09:29
      численность           население через год   1   40000                             42000   2   42000                             44100   3   44100                             46305 переменная 1 = 3 переменная 2 =  46305    
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота