В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ksenia231106
ksenia231106
03.02.2020 20:46 •  Информатика

Умоляю Определите результат выполнения фрагмента программы при, x =8
2) Запишите составное условие на языке Python
3)Укажите формулу ветвления, используемую в представленной программе ​


Умоляю Определите результат выполнения фрагмента программы при, x =82) Запишите составное условие на

Показать ответ
Ответ:
manawer
manawer
14.01.2020 19:45
Ну функция randomize() создаёт, перемешивает новые рандомные числа, а random() их предоставляет.
Разных вариаций написания много, я например сделал с массивом, можно в принципе и без него, но с ним лучше т.к. числа хранятся в массиве и их можно выводить в будущем, если это слишком сложно для тебя, то я могу написать программу без использования массива.

Var i,b:integer;
    A:array[1..20] of integer;
Begin
  Randomize();
  for i:=1 to 20 do
  A[i]:=Random(0,50);
Write('Из чисел: ');
   for i:=1 to 20 do
    begin
    if i=20 then
      Writeln(A[i])
       else Write(A[i],', ')
    end;
Write('Кол-во четных равняется: ');
  for i:=1 to 20 do
             if (A[i] mod 2 = 0) then b:=b+1;
Writeln(b)
End.

Вот выводы программы, которые у меня получились.

Первый раз:
Из чисел: 42, 1, 46, 24, 36, 9, 22, 16, 7, 41, 49, 46, 27, 29, 50, 44, 44, 10, 48, 36
Кол-во четных равняется: 13

Второй раз:
Из чисел: 5, 16, 16, 27, 1, 48, 46, 45, 46, 13, 21, 18, 24, 45, 14, 13, 33, 14, 21, 30
Кол-во четных равняется: 10

Третий раз:
Из чисел: 15, 2, 24, 42, 49, 43, 5, 48, 8, 1, 45, 9, 20, 24, 35, 19, 11, 15, 26, 33
Кол-во четных равняется: 8

Файл с кодом прикреплю во вложения, спрашивай если не понятна какая-то функция, объясню, дабы ты не стоял в ступоре перед учительницей...
0,0(0 оценок)
Ответ:
Lraaq
Lraaq
04.03.2022 05:45
1 v 0 & 1 = 11 & 1 v 0 & 1  = 10 v 1 & 1 = 10 & 1 & 1 v 0 v 1 = 11 v 1 & 0 v 0  = 1A v 0 & 1 = AB & 1 v 0 & 1 = B

Объяснение:

Порядок действий:

1) Дизъюнкция (И) Умножение [&, ∧] - для истинности необходимо, чтобы все элементы был истинными.

2) Конъюнкция (ИЛИ) Сложение [∨, +] - для истинности необходимо, чтобы хотя бы один элемент был истинным.

1 v 0 & 1 = 1

0 & 1 = 01 v 0 = 1

1 & 1 v 0 & 1  = 1

1 & 1 = 10 & 1 = 01 v 0 = 1

0 v 1 & 1 = 1

1 & 1 = 10 v 1 = 1

0 & 1 & 1 v 0 v 1 = 1

0 & 1 = 00 & 1 = 00 v 0 = 00 v 1 = 1

1 v 1 & 0 v 0  = 1

1 & 0 = 01 v 0 = 11 v 0 = 1

A v 0 & 1 = A

0 & 1 = 0A v 0 = A

Закон исключения констант:

A v 0 = A

B & 1 v 0 & 1 = B

B & 1 = B

Закон исключения констант:

A & 1 = A

0 & 1 = 0B v 0 = B

Закон исключения констант:

A v 0 = A

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота