В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
lilipute2017
lilipute2017
23.04.2020 20:39 •  Информатика

Задание: решить с цикла ПОКА. Написать программу в КУМИРе
Решите хотябы одно задание, для примера

Показать ответ
Ответ:
RengevychPolina
RengevychPolina
04.09.2022 13:45
Class OftenChar{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in);
  String string = in.nextLine(); char chars[] = new char[4];
  chars[0] = in.nextLine().charAt(0); chars[2] = in.nextLine().charAt(0);
  for(int sChar = 0; sChar<string.length(); sChar++)
   if(string.charAt(sChar)==chars[0])chars[1]++;
   else if(string.charAt(sChar)==chars[2])chars[3]++;
  System.out.print("\n"+(chars[1]==chars[3]?chars[0]+""+chars[2]:chars[1]>chars[3]?chars[0]:chars[2]));
 }
}
0,0(0 оценок)
Ответ:
tigranpesoz3twi
tigranpesoz3twi
03.01.2020 08:34

Код программы:

#include <iostream>

#include <locale>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

double D, a, b, c, x1, x2;

cout<<"Введите коэффициент a" << endl;

cin >> a;

if (a == 0) {

 cout << "Ошибка ввода! Коэффициент a не должен равняться 0" << endl;

 return 0;

}

cout << "Введите коэффициент b" << endl;

cin >> b;

cout << "Введите коэффициент c" << endl;

cin >> c;

cout << "\nВаше уравнение: " << a << "x^(2) + " << b << "x + " << c << endl;

D = sqrt(b*b - 4 * a * c);

if (D >= 0) {

 if (D == 0) {

  x1 = (-b) / (2 * a);

  cout << "x1 = " << x1 << endl;

 }

 else {

  x1 = (-b - D) / (2 * a);

  x2 = (-b + D) / (2 * a);

  cout << "x1 = " << x1 << endl;

  cout << "x2 = " << x2 << endl;

 }

}

else

 cout << "\nУравнение не имеет корней (D < 0)" << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота